diff setup.py @ 1808:202ac6c94b7f

hgext3rd: move 'simple4server' as 'evolve.serveronly' We also more the server only extension into hgext3rd. We makes it a python sub-module of evolve for two reasons: * less polution in the hgext3rd namespace, * this make it possible to share the code between 'evolve' and 'evolve.serveronly' instead of duplicating it. note that we now install the extension too
author Pierre-Yves David <pierre-yves.david@ens-lyon.org>
date Tue, 01 Nov 2016 16:07:28 +0100
parents a53efee7d8b0
children 143c8e4dc22d
line wrap: on
line diff
--- a/setup.py	Tue Feb 28 14:36:18 2017 +0100
+++ b/setup.py	Tue Nov 01 16:07:28 2016 +0100
@@ -15,10 +15,11 @@
           if "'" in line:
             return line.split("'")[1]
 
-py_modules = []
+py_modules = [
+    'hgext3rd.evolve.serveronly'
+]
 py_packages = [
     'hgext3rd',
-    'hgext3rd.evolve',
 ]
 
 if os.environ.get('INCLUDE_INHIBIT'):