diff setup.py @ 1929:99f983e8e18f

setup: make sure we use the imported module This prevent pyflakes to complains about it (and work around any possible demand import magic. I'm not sure why we do this important dance at all, but I'm leaving it there in doubt.
author Pierre-Yves David <pierre-yves.david@fb.com>
date Mon, 28 Mar 2016 00:50:36 -0700
parents 769b2b271422
children 192c9f92148d
line wrap: on
line diff
--- a/setup.py	Mon Mar 21 21:38:56 2016 -0700
+++ b/setup.py	Mon Mar 28 00:50:36 2016 -0700
@@ -3,6 +3,7 @@
 requires = []
 try:
     import mercurial
+    mercurial.__all__
 except ImportError:
     requires.append('mercurial')