Mercurial > public > mercurial-scm > hg-stable
comparison mercurial/subrepo.py @ 14220:21b8ce4d3331
rename path_auditor to pathauditor
The Mercurial 1.9 release is moving a lot of stuff around anyway and we are
already moving path_auditor from util.py to scmutil.py for that release.
So this seems like a good opportunity to do such a rename. It also strengthens
the current project policy to avoid underbars in names.
author | Adrian Buehlmann <adrian@cadifra.com> |
---|---|
date | Fri, 06 May 2011 09:54:06 +0200 |
parents | 924c82157d46 |
children | 680c3c6fcb48 |
comparison
equal
deleted
inserted
replaced
14219:c33427080671 | 14220:21b8ce4d3331 |
---|---|
233 # scripts that don't use our demand-loading | 233 # scripts that don't use our demand-loading |
234 global hg | 234 global hg |
235 import hg as h | 235 import hg as h |
236 hg = h | 236 hg = h |
237 | 237 |
238 scmutil.path_auditor(ctx._repo.root)(path) | 238 scmutil.pathauditor(ctx._repo.root)(path) |
239 state = ctx.substate.get(path, nullstate) | 239 state = ctx.substate.get(path, nullstate) |
240 if state[2] not in types: | 240 if state[2] not in types: |
241 raise util.Abort(_('unknown subrepo type %s') % state[2]) | 241 raise util.Abort(_('unknown subrepo type %s') % state[2]) |
242 return types[state[2]](ctx, path, state[:2]) | 242 return types[state[2]](ctx, path, state[:2]) |
243 | 243 |