diff setup.py @ 32904:19b0fd4b5570

plan9: drop py26 hacks
author Matt Harbison <matt_harbison@yahoo.com>
date Fri, 16 Jun 2017 18:42:03 -0400
parents 9a4adc76c88a
children 20fc5d39d0c1
line wrap: on
line diff
--- a/setup.py	Sun Jun 18 12:25:23 2017 +0900
+++ b/setup.py	Fri Jun 16 18:42:03 2017 -0400
@@ -143,17 +143,10 @@
     py2exeloaded = False
 
 def runcmd(cmd, env):
-    if (sys.platform == 'plan9'
-       and (sys.version_info[0] == 2 and sys.version_info[1] < 7)):
-        # subprocess kludge to work around issues in half-baked Python
-        # ports, notably bichued/python:
-        _, out, err = os.popen3(cmd)
-        return str(out), str(err)
-    else:
-        p = subprocess.Popen(cmd, stdout=subprocess.PIPE,
-                             stderr=subprocess.PIPE, env=env)
-        out, err = p.communicate()
-        return out, err
+    p = subprocess.Popen(cmd, stdout=subprocess.PIPE,
+                         stderr=subprocess.PIPE, env=env)
+    out, err = p.communicate()
+    return out, err
 
 def runhg(cmd, env):
     out, err = runcmd(cmd, env)