diff setup.py @ 15273:384082750f2c stable 2.0-rc

merge default into stable for 2.0 code freeze
author Matt Mackall <mpm@selenic.com>
date Sat, 15 Oct 2011 14:30:50 -0500
parents c41078b9d0b8
children b357a972d6cd
line wrap: on
line diff
--- a/setup.py	Sun Oct 02 16:41:07 2011 -0500
+++ b/setup.py	Sat Oct 15 14:30:50 2011 -0500
@@ -5,7 +5,7 @@
 # 'python setup.py --help' for more options
 
 import sys, platform
-if not hasattr(sys, 'version_info') or sys.version_info < (2, 4, 0, 'final'):
+if getattr(sys, 'version_info', (0, 0, 0)) < (2, 4, 0, 'final'):
     raise SystemExit("Mercurial requires Python 2.4 or later.")
 
 if sys.version_info[0] >= 3:
@@ -342,7 +342,8 @@
 
 packages = ['mercurial', 'mercurial.hgweb',
             'mercurial.httpclient', 'mercurial.httpclient.tests',
-            'hgext', 'hgext.convert', 'hgext.highlight', 'hgext.zeroconf']
+            'hgext', 'hgext.convert', 'hgext.highlight', 'hgext.zeroconf',
+            'hgext.largefiles']
 
 pymodules = []