diff setup.py @ 29505:2dce3f96ad7b

setup: prepare for future cffi modules by adding placeholder in setup
author Maciej Fijalkowski <fijall@gmail.com>
date Mon, 11 Jul 2016 10:44:18 +0200
parents 284d742e5611
children 9631ff5ebbeb
line wrap: on
line diff
--- a/setup.py	Fri Jul 08 16:48:38 2016 +0100
+++ b/setup.py	Mon Jul 11 10:44:18 2016 +0200
@@ -262,7 +262,8 @@
 
 
 class hgdist(Distribution):
-    pure = ispypy
+    pure = False
+    cffi = ispypy
 
     global_options = Distribution.global_options + \
                      [('pure', None, "use pure (slow) Python "
@@ -316,6 +317,10 @@
 
         if self.distribution.pure:
             self.distribution.ext_modules = []
+        elif self.distribution.cffi:
+            exts = []
+            # cffi modules go here
+            self.distribution.ext_modules = exts
         else:
             h = os.path.join(get_python_inc(), 'Python.h')
             if not os.path.exists(h):