diff contrib/python-zstandard/setup.py @ 52681:3e84e001b6c1

pyupgrade: drop redundant `open()` modes On one hand, this gets rid of some py2 cruft (like `U` and `t` modes). OTOH, I like being explict. But there's no way to disable individual transformations (and this change is part of `_fix_tokens()`, which is even harder to selectively use locally), and I'd rather have less noise when using `pyupgrade`. Warning: `contrib/synthrepo.py` appears not to have been updated to py3, as it's passing str to `error.Abort`. But since it was opening the file in unicode on py2, this change is a no-op.
author Matt Harbison <matt_harbison@yahoo.com>
date Tue, 07 Jan 2025 17:28:46 -0500
parents 6000f5b25c9b
children f8f14e6d032b
line wrap: on
line diff
--- a/contrib/python-zstandard/setup.py	Mon Jan 06 01:44:46 2025 -0500
+++ b/contrib/python-zstandard/setup.py	Tue Jan 07 17:28:46 2025 -0500
@@ -77,7 +77,7 @@
 
 version = None
 
-with open("c-ext/python-zstandard.h", "r") as fh:
+with open("c-ext/python-zstandard.h") as fh:
     for line in fh:
         if not line.startswith("#define PYTHON_ZSTANDARD_VERSION"):
             continue
@@ -94,7 +94,7 @@
     name="zstandard",
     version=version,
     description="Zstandard bindings for Python",
-    long_description=open("README.rst", "r").read(),
+    long_description=open("README.rst").read(),
     url="https://github.com/indygreg/python-zstandard",
     author="Gregory Szorc",
     author_email="gregory.szorc@gmail.com",