diff setup.py @ 10005:68964567e406

setup: install some useful data files. The selection is somewhat arbitrary. In the case of the Zsh completion file, it will not conflict with the builtin Zsh completions: they are in a file named `_mercurial', not `_hg'.
author Dan Villiom Podlaski Christiansen <danchr@gmail.com>
date Mon, 30 Nov 2009 21:54:34 +0100
parents 16f49d671c7f
children 873d9b9a7bac
line wrap: on
line diff
--- a/setup.py	Mon Nov 30 23:10:21 2009 +0200
+++ b/setup.py	Mon Nov 30 21:54:34 2009 +0100
@@ -263,7 +263,16 @@
             f = os.path.join(curdir, f)
             packagedata['mercurial'].append(f)
 
-datafiles = []
+datafiles = [
+    ('share/bash_completion.d', ['contrib/bash/hg']),
+    ('share/zsh/site-functions', ['contrib/zsh/_hg']),
+    ('share/mercurial/www', ['hgweb.cgi',
+                             'hgwebdir.cgi',
+                             'contrib/hgwebdir.fcgi',
+                             'contrib/hgwebdir.wsgi']),
+    ('share/mercurial/examples', ['contrib/sample.hgrc',
+                                  'contrib/mergetools.hgrc']),
+]
 
 setup(name='mercurial',
       version=version,