diff setup.py @ 14243:861f28212398

Import new http library as mercurial.httpclient. This is revision a4229f13c374 of http://py-nonblocking-http.googlecode.com/ with a no-check-code comment added to the end of each file using `for fi in $(hg manifest | grep mercurial/httpclient/) ; echo '# no-check-code' >> $fi`.
author Augie Fackler <durin42@gmail.com>
date Fri, 06 May 2011 09:57:55 -0500
parents 16118b4859a1
children bb7e3b3e6e11
line wrap: on
line diff
--- a/setup.py	Fri May 06 15:48:04 2011 -0300
+++ b/setup.py	Fri May 06 09:57:55 2011 -0500
@@ -301,8 +301,9 @@
             'build_py': hgbuildpy,
             'install_scripts': hginstallscripts}
 
-packages = ['mercurial', 'mercurial.hgweb', 'hgext', 'hgext.convert',
-            'hgext.highlight', 'hgext.zeroconf']
+packages = ['mercurial', 'mercurial.hgweb',
+            'mercurial.httpclient', 'mercurial.httpclient.tests',
+            'hgext', 'hgext.convert', 'hgext.highlight', 'hgext.zeroconf']
 
 pymodules = []