diff setup.py @ 44058:bde1cd4c99d9

sha1dc: initial implementation of Python extension A future change will use this when available to avoid sha1 collision issues until we can get moved to something else. Differential Revision: https://phab.mercurial-scm.org/D7815
author Augie Fackler <augie@google.com>
date Wed, 08 Jan 2020 15:59:52 -0500
parents 44b03c0313aa
children 4e05272dd681
line wrap: on
line diff
--- a/setup.py	Wed Jan 08 15:09:01 2020 -0500
+++ b/setup.py	Wed Jan 08 15:59:52 2020 -0500
@@ -1481,6 +1481,14 @@
         ],
     ),
     Extension(
+        'mercurial.thirdparty.sha1dc',
+        [
+            'mercurial/thirdparty/sha1dc/cext.c',
+            'mercurial/thirdparty/sha1dc/lib/sha1.c',
+            'mercurial/thirdparty/sha1dc/lib/ubc_check.c',
+        ],
+    ),
+    Extension(
         'hgext.fsmonitor.pywatchman.bser', ['hgext/fsmonitor/pywatchman/bser.c']
     ),
     RustStandaloneExtension(