diff setup.py @ 52437:c28ba6fb3fae

rust-pyo3: change the name of the Python module to pyo3_rustext Two reasons for doing so - `pyo3-rustext` is not a valid Python identifier, hence the module could only be imported with `__import__("mercurial.pyo3-rustext")` and then retrieved by getattr. Normal usage is throught `mercurial.policy`. Hovever manual testing for development and perhaps unit tests can benefit a more natural way of doing. - The module's `__name__` attribute was already `pyo3_rustext`. This can lead to some discrepancies, in particular when we introduce submodules.
author Georges Racinet <georges.racinet@cloudcrane.io>
date Fri, 29 Nov 2024 22:59:16 +0100
parents 6673cec8605c
children 0a81f3ef054c
line wrap: on
line diff
--- a/setup.py	Sat Nov 30 19:12:02 2024 +0100
+++ b/setup.py	Fri Nov 29 22:59:16 2024 +0100
@@ -1663,7 +1663,7 @@
         'librusthg',
     ),
     RustStandaloneExtension(
-        'mercurial.pyo3-rustext',
+        'mercurial.pyo3_rustext',
         'hg-pyo3',
         'librusthgpyo3',
     ),