diff pyproject.toml @ 46454:d4c8b4b90ecb

black: merge config into main pyproject.toml now that we have it This means that naive contributors who just run `black` on a source file will get reasonable behavior as long as they have a recent black. Yay! Differential Revision: https://phab.mercurial-scm.org/D9834
author Augie Fackler <augie@google.com>
date Tue, 01 Dec 2020 12:59:33 -0500
parents 45afff0f530a
children 5be886200eb6 58fe6d127a01
line wrap: on
line diff
--- a/pyproject.toml	Tue Dec 01 12:52:04 2020 -0500
+++ b/pyproject.toml	Tue Dec 01 12:59:33 2020 -0500
@@ -1,3 +1,18 @@
 [build-system]
 requires = ["setuptools", "wheel"]
 build-backend = "setuptools.build_meta"
+
+[tool.black]
+line-length = 80
+exclude = '''
+build/
+| wheelhouse/
+| dist/
+| packages/
+| \.hg/
+| \.mypy_cache/
+| \.venv/
+| mercurial/thirdparty/
+'''
+skip-string-normalization = true
+quiet = true