diff setup.py @ 7801:e5627562b9f2

setup: run hg with empty HGRCPATH for robustness. Otherwise a bad hgrc file can make the version detection fail.
author Martin Geisler <mg@daimi.au.dk>
date Tue, 24 Feb 2009 18:09:16 +0100
parents 1817e45c2212
children f0a7accf1d68
line wrap: on
line diff
--- a/setup.py	Tue Feb 24 16:05:43 2009 +0100
+++ b/setup.py	Tue Feb 24 18:09:16 2009 +0100
@@ -103,6 +103,7 @@
     pypath = os.environ.get('PYTHONPATH', '')
     purepath = os.path.join('mercurial', 'pure')
     os.environ['PYTHONPATH'] = os.pathsep.join(['mercurial', purepath, pypath])
+    os.environ['HGRCPATH'] = '' # do not read any config file
     cmd = '%s hg id -it' % sys.executable
     l = os.popen(cmd).read().split()
     os.environ['PYTHONPATH'] = pypath