diff setup.py @ 6009:f077815932ce

filemerge: remove the hgmerge script This is now better handled using [merge-tools] and [merge-patterns] in hgrc.
author Matt Mackall <mpm@selenic.com>
date Sun, 03 Feb 2008 19:29:05 -0600
parents f22708f50213
children 39cfcef4f463
line wrap: on
line diff
--- a/setup.py	Sun Feb 03 19:29:05 2008 -0600
+++ b/setup.py	Sun Feb 03 19:29:05 2008 -0600
@@ -40,11 +40,6 @@
 except ImportError:
     pass
 
-if os.name in ['nt']:
-    extra['scripts'] = ['hg']
-else:
-    extra['scripts'] = ['hg', 'hgmerge']
-
 # specify version string, otherwise 'hg identify' will be used:
 version = ''
 
@@ -77,6 +72,7 @@
       url='http://selenic.com/mercurial',
       description='Scalable distributed SCM',
       license='GNU GPL',
+      scripts=['hg'],
       packages=['mercurial', 'mercurial.hgweb', 'hgext', 'hgext.convert'],
       ext_modules=ext_modules,
       data_files=[(os.path.join('mercurial', root),