diff setup.py @ 16689:f366d4c2ff34

cleanup: replace naked excepts with except Exception: ...
author Brodie Rao <brodie@sf.io>
date Sat, 12 May 2012 16:02:46 +0200
parents cfb6682961b8
children e6af8676302f
line wrap: on
line diff
--- a/setup.py	Sat May 12 16:02:45 2012 +0200
+++ b/setup.py	Sat May 12 16:02:46 2012 +0200
@@ -108,7 +108,7 @@
             os.dup2(devnull.fileno(), sys.stderr.fileno())
             objects = cc.compile([fname], output_dir=tmpdir)
             cc.link_executable(objects, os.path.join(tmpdir, "a.out"))
-        except:
+        except Exception:
             return False
         return True
     finally: