diff setup.py @ 32273:feb910d2f59b

setup: drop support for Python 2.6 (BC) Per discussion on the mailing list and elsewhere, we've decided that Python 2.6 is too old to continue supporting. We keep accumulating hacks/fixes/workarounds for 2.6 and this is taking time away from more important work. So with this patch, we officially drop support for Python 2.6 and require Python 2.7 to run Mercurial.
author Gregory Szorc <gregory.szorc@gmail.com>
date Tue, 02 May 2017 16:19:04 -0700
parents c48583859e04
children a04f5c651e52
line wrap: on
line diff
--- a/setup.py	Sat May 06 11:16:59 2017 -0700
+++ b/setup.py	Tue May 02 16:19:04 2017 -0700
@@ -5,8 +5,8 @@
 # 'python setup.py --help' for more options
 
 import sys, platform
-if sys.version_info < (2, 6, 0, 'final'):
-    raise SystemExit("Mercurial requires Python 2.6 or later.")
+if sys.version_info < (2, 7, 0, 'final'):
+    raise SystemExit('Mercurial requires Python 2.7 or later.')
 
 if sys.version_info[0] >= 3:
     printf = eval('print')