comparison mercurial/merge.py @ 14220:21b8ce4d3331

rename path_auditor to pathauditor The Mercurial 1.9 release is moving a lot of stuff around anyway and we are already moving path_auditor from util.py to scmutil.py for that release. So this seems like a good opportunity to do such a rename. It also strengthens the current project policy to avoid underbars in names.
author Adrian Buehlmann <adrian@cadifra.com>
date Fri, 06 May 2011 09:54:06 +0200
parents 135e244776f0
children df2399663392
comparison
equal deleted inserted replaced
14219:c33427080671 14220:21b8ce4d3331
300 for f in moves: 300 for f in moves:
301 if os.path.lexists(repo.wjoin(f)): 301 if os.path.lexists(repo.wjoin(f)):
302 repo.ui.debug("removing %s\n" % f) 302 repo.ui.debug("removing %s\n" % f)
303 os.unlink(repo.wjoin(f)) 303 os.unlink(repo.wjoin(f))
304 304
305 audit_path = scmutil.path_auditor(repo.root) 305 audit_path = scmutil.pathauditor(repo.root)
306 306
307 numupdates = len(action) 307 numupdates = len(action)
308 for i, a in enumerate(action): 308 for i, a in enumerate(action):
309 f, m = a[:2] 309 f, m = a[:2]
310 u.progress(_('updating'), i + 1, item=f, total=numupdates, 310 u.progress(_('updating'), i + 1, item=f, total=numupdates,