setup.py
changeset 21840 0c88185c7d6c
parent 21558 8b482d49563b
parent 21839 f266be73f764
child 22198 77142de48ae4
--- a/setup.py	Fri Jun 13 15:59:18 2014 -0700
+++ b/setup.py	Sun Jul 06 15:39:01 2014 -0400
@@ -534,7 +534,7 @@
     # so Mercurial can continue to compile in the meantime.
     if xcode51:
         cflags = get_config_var('CFLAGS')
-        if re.search(r'-mno-fused-madd\b', cflags) is not None:
+        if cflags and re.search(r'-mno-fused-madd\b', cflags) is not None:
             os.environ['CFLAGS'] = (
                 os.environ.get('CFLAGS', '') + ' -Qunused-arguments')