diff mercurial/subrepo.py @ 14220:21b8ce4d3331

rename path_auditor to pathauditor The Mercurial 1.9 release is moving a lot of stuff around anyway and we are already moving path_auditor from util.py to scmutil.py for that release. So this seems like a good opportunity to do such a rename. It also strengthens the current project policy to avoid underbars in names.
author Adrian Buehlmann <adrian@cadifra.com>
date Fri, 06 May 2011 09:54:06 +0200
parents 924c82157d46
children 680c3c6fcb48
line wrap: on
line diff
--- a/mercurial/subrepo.py	Fri May 06 12:09:20 2011 +0200
+++ b/mercurial/subrepo.py	Fri May 06 09:54:06 2011 +0200
@@ -235,7 +235,7 @@
     import hg as h
     hg = h
 
-    scmutil.path_auditor(ctx._repo.root)(path)
+    scmutil.pathauditor(ctx._repo.root)(path)
     state = ctx.substate.get(path, nullstate)
     if state[2] not in types:
         raise util.Abort(_('unknown subrepo type %s') % state[2])