diff setup.py @ 28432:2377c4ac4eec

fsmonitor: dependencies for new experimental extension In preparation for the filesystem monitor extension, include the pywatchman library. The fbmonitor extension relies on this library to communicate with the Watchman service. The library is BSD licensed and is taken from https://github.com/facebook/watchman/tree/master/python. This package has not been updated to mercurial code standards.
author Martijn Pieters <mjpieters@fb.com>
date Wed, 02 Mar 2016 16:25:12 +0000
parents a7e3b72cf756
children 4b81487a01d4
line wrap: on
line diff
--- a/setup.py	Tue Jan 12 04:45:29 2016 +0000
+++ b/setup.py	Wed Mar 02 16:25:12 2016 +0000
@@ -532,6 +532,8 @@
     Extension('mercurial.osutil', ['mercurial/osutil.c'],
               extra_link_args=osutil_ldflags,
               depends=common_depends),
+    Extension('hgext.fsmonitor.pywatchman.bser',
+              ['hgext/fsmonitor/pywatchman/bser.c']),
     ]
 
 try: