contrib/python-zstandard/setup.py
changeset 52656 3e84e001b6c1
parent 48875 6000f5b25c9b
child 52728 f8f14e6d032b
--- a/contrib/python-zstandard/setup.py	Mon Jan 06 01:44:46 2025 -0500
+++ b/contrib/python-zstandard/setup.py	Tue Jan 07 17:28:46 2025 -0500
@@ -77,7 +77,7 @@
 
 version = None
 
-with open("c-ext/python-zstandard.h", "r") as fh:
+with open("c-ext/python-zstandard.h") as fh:
     for line in fh:
         if not line.startswith("#define PYTHON_ZSTANDARD_VERSION"):
             continue
@@ -94,7 +94,7 @@
     name="zstandard",
     version=version,
     description="Zstandard bindings for Python",
-    long_description=open("README.rst", "r").read(),
+    long_description=open("README.rst").read(),
     url="https://github.com/indygreg/python-zstandard",
     author="Gregory Szorc",
     author_email="gregory.szorc@gmail.com",