Mercurial > public > mercurial-scm > hg
diff mercurial/bundle2.py @ 42002:662ffdde5adf
branchcache: rename itervalues() to iterheads()
The itervalues() exists because branchcache() had a dict interface. Since it no
longer has a dict interface, it makes sense to have better function names.
If a person does not understand how branchcache stores info, it will be hard for
them to guess what itervalues() does.
Differential Revision: https://phab.mercurial-scm.org/D6152
author | Pulkit Goyal <pulkit@yandex-team.ru> |
---|---|
date | Mon, 18 Mar 2019 19:01:29 +0300 |
parents | 2d835c42ab41 |
children | 566daffc607d |
line wrap: on
line diff
--- a/mercurial/bundle2.py Mon Mar 18 18:59:38 2019 +0300 +++ b/mercurial/bundle2.py Mon Mar 18 19:01:29 2019 +0300 @@ -1980,7 +1980,7 @@ op.gettransaction() currentheads = set() - for ls in op.repo.branchmap().itervalues(): + for ls in op.repo.branchmap().iterheads(): currentheads.update(ls) for h in heads: