Mercurial > public > mercurial-scm > hg
diff mercurial/revset.py @ 42002:662ffdde5adf
branchcache: rename itervalues() to iterheads()
The itervalues() exists because branchcache() had a dict interface. Since it no
longer has a dict interface, it makes sense to have better function names.
If a person does not understand how branchcache stores info, it will be hard for
them to guess what itervalues() does.
Differential Revision: https://phab.mercurial-scm.org/D6152
author | Pulkit Goyal <pulkit@yandex-team.ru> |
---|---|
date | Mon, 18 Mar 2019 19:01:29 +0300 |
parents | 5fe4de392edb |
children | 0bd730fbcc2b |
line wrap: on
line diff
--- a/mercurial/revset.py Mon Mar 18 18:59:38 2019 +0300 +++ b/mercurial/revset.py Mon Mar 18 19:01:29 2019 +0300 @@ -1240,7 +1240,7 @@ getargs(x, 0, 0, _("head takes no arguments")) hs = set() cl = repo.changelog - for ls in repo.branchmap().itervalues(): + for ls in repo.branchmap().iterheads(): hs.update(cl.rev(h) for h in ls) return subset & baseset(hs)