diff setup.py @ 32378:7d0c69505a66

cext: extract revlog/index parsing code to own C file parsers.c is ~3000 lines and ~2/3 of it is related to the revlog index type. We already have separate C source files for directory utilities and manifest parsing. I think the quite unwieldy revlog/index parsing code should be self-contained as well. I performed the extraction as a file copy then removed content from both sides in order to preserve file history and blame. As part of this, I also had to move the hexdigit table and function to a shared header since it is used by both parsers.c and revlog.c # no-check-commit
author Gregory Szorc <gregory.szorc@gmail.com>
date Sat, 20 May 2017 14:01:05 -0700
parents df448de7cf3b
children 34bd3cd28dcb
line wrap: on
line diff
--- a/setup.py	Thu May 04 17:13:12 2017 +0900
+++ b/setup.py	Sat May 20 14:01:05 2017 -0700
@@ -638,7 +638,8 @@
     Extension('mercurial.cext.parsers', ['mercurial/cext/dirs.c',
                                          'mercurial/cext/manifest.c',
                                          'mercurial/cext/parsers.c',
-                                         'mercurial/cext/pathencode.c'],
+                                         'mercurial/cext/pathencode.c',
+                                         'mercurial/cext/revlog.c'],
               include_dirs=common_include_dirs,
               depends=common_depends),
     Extension('mercurial.cext.osutil', ['mercurial/cext/osutil.c'],