Mercurial > public > mercurial-scm > hg
diff mercurial/wireproto.py @ 36070:90ca4986616c
wireprotoserver: rename getfile() to forwardpayload() (API)
"file" can mean a lot of things. Let's rename the interface
method to something more descriptive.
While I was here, I moved the docs about the payload format to
the implementation of the SSH protocol, because it was lying
about what the HTTP payload looked like.
Differential Revision: https://phab.mercurial-scm.org/D2085
author | Gregory Szorc <gregory.szorc@gmail.com> |
---|---|
date | Thu, 01 Feb 2018 17:12:07 -0800 |
parents | 957e773614d0 |
children | 038bcb759b75 |
line wrap: on
line diff
--- a/mercurial/wireproto.py Wed Feb 07 20:24:22 2018 -0800 +++ b/mercurial/wireproto.py Thu Feb 01 17:12:07 2018 -0800 @@ -1008,7 +1008,7 @@ fp = os.fdopen(fd, pycompat.sysstr('wb+')) r = 0 try: - proto.getfile(fp) + proto.forwardpayload(fp) fp.seek(0) gen = exchange.readbundle(repo.ui, fp, None) if (isinstance(gen, changegroupmod.cg1unpacker)