Mercurial > public > mercurial-scm > hg
diff mercurial/exchange.py @ 30582:94de83ed250e
bookmarks: rename `compare()` to `comparebookmarks()` (API)
Next commit will remove optional parameters from `compare()` function.
Let's rename `compare()` to `comparebookmarks()` to avoid ambiguity from
callers from external extensions.
author | Stanislau Hlebik <stash@fb.com> |
---|---|
date | Tue, 22 Nov 2016 01:33:31 -0800 |
parents | 8491845a75b2 |
children | 8f8211903b83 |
line wrap: on
line diff
--- a/mercurial/exchange.py Mon Dec 05 17:40:01 2016 +0100 +++ b/mercurial/exchange.py Tue Nov 22 01:33:31 2016 -0800 @@ -603,7 +603,8 @@ explicit = set([repo._bookmarks.expandname(bookmark) for bookmark in pushop.bookmarks]) - comp = bookmod.compare(repo, repo._bookmarks, remotebookmark, srchex=hex) + comp = bookmod.comparebookmarks(repo, repo._bookmarks, + remotebookmark, srchex=hex) addsrc, adddst, advsrc, advdst, diverge, differ, invalid, same = comp for b, scid, dcid in advsrc: if b in explicit: