diff setup.py @ 7712:9f9bbd33f71e

i18n: check format strings when building xx.mo files
author Martin Geisler <mg@daimi.au.dk>
date Sun, 25 Jan 2009 20:27:37 +0100
parents a489e3a94443
children b6c2cb40e664
line wrap: on
line diff
--- a/setup.py	Sun Jan 25 20:16:35 2009 +0100
+++ b/setup.py	Sun Jan 25 20:27:37 2009 +0100
@@ -141,7 +141,7 @@
             mofile = join(modir, 'hg.mo')
             self.mkpath(modir)
             self.make_file([pofile], mofile, spawn,
-                           (['msgfmt', '-o', mofile, pofile],))
+                           (['msgfmt', '-v', '-c', '-o', mofile, pofile],))
             self.distribution.data_files.append((join('mercurial', modir),
                                                  [mofile]))