diff setup.py @ 24214:a5f1bccd2996

manifest.c: new extension code to lazily parse manifests This lets us iterate manifests in order, but do a _lot_ less work in the common case when we only care about a few manifest entries. Many thanks to Mike Edgar for reviewing this in advance of it going out to the list, which caught many things I missed. This version of the patch includes C89 fixes from Sean Farley and many correctness/efficiency cleanups from Martin von Zweigbergk. Thanks to both!
author Augie Fackler <augie@google.com>
date Tue, 13 Jan 2015 14:31:38 -0800
parents 390410a6545d
children 9c1942635c1f
line wrap: on
line diff
--- a/setup.py	Thu Mar 05 22:16:28 2015 -0800
+++ b/setup.py	Tue Jan 13 14:31:38 2015 -0800
@@ -493,6 +493,7 @@
     Extension('mercurial.mpatch', ['mercurial/mpatch.c'],
               depends=common_depends),
     Extension('mercurial.parsers', ['mercurial/dirs.c',
+                                    'mercurial/manifest.c',
                                     'mercurial/parsers.c',
                                     'mercurial/pathencode.c'],
               depends=common_depends),