diff setup.py @ 9539:c904e76e3834

help: move help topics from mercurial/help.py to help/*.txt The help topics are loaded on demand so we wont hit the disk unless we really have to.
author Martin Geisler <mg@lazybytes.net>
date Sun, 04 Oct 2009 09:59:13 +0200
parents 63cfacb7917e
children f51d1822d6fd
line wrap: on
line diff
--- a/setup.py	Sat Oct 03 18:58:25 2009 +0200
+++ b/setup.py	Sun Oct 04 09:59:13 2009 +0200
@@ -246,7 +246,7 @@
         packages.extend(['hgext.inotify', 'hgext.inotify.linux'])
 
 datafiles = []
-for root in ('templates', 'i18n'):
+for root in ('templates', 'i18n', 'help'):
     for dir, dirs, files in os.walk(root):
         dirs[:] = [x for x in dirs if not x.startswith('.')]
         files = [x for x in files if not x.startswith('.')]