diff setup.py @ 52321:dd8e7d4fe8c3

setup_py: imports standard lib at the top
author paugier <pierre.augier@univ-grenoble-alpes.fr>
date Sat, 23 Nov 2024 06:07:40 +0100
parents ad23dc96e7d6
children 40f649592ba9
line wrap: on
line diff
--- a/setup.py	Thu Oct 24 15:18:37 2024 +0200
+++ b/setup.py	Sat Nov 23 06:07:40 2024 +0100
@@ -1,9 +1,16 @@
 # This is the mercurial setup script.
 
+import ctypes
 import os
+import re
+import shutil
+import ssl
+import stat
+import subprocess
 import sys
 import sysconfig
-import ssl
+import tempfile
+import time
 
 if not ssl.HAS_TLSv1_2:
     error = """
@@ -52,12 +59,6 @@
 
 ispypy = "PyPy" in sys.version
 
-import ctypes
-import stat, subprocess, time
-import re
-import shutil
-import tempfile
-
 # We have issues with setuptools on some platforms and builders. Until
 # those are resolved, setuptools is opt-in except for platforms where
 # we don't have issues.