setup.py
changeset 52662 e5aadff6cb7d
parent 52661 958d5c998505
child 52663 25bb409da058
--- a/setup.py	Wed Dec 04 22:52:58 2024 +0100
+++ b/setup.py	Mon Dec 30 20:56:19 2024 -0500
@@ -1659,18 +1659,21 @@
         ['hgext/fsmonitor/pywatchman/bser.c'],
         extra_compile_args=common_cflags,
     ),
-    RustStandaloneExtension(
-        'mercurial.rustext',
-        'hg-cpython',
-        'librusthg',
-    ),
-    RustStandaloneExtension(
-        'mercurial.pyo3_rustext',
-        'hg-pyo3',
-        'librusthgpyo3',
-    ),
 ]
 
+if os.name != 'nt':
+    extmodules += [
+        RustStandaloneExtension(
+            'mercurial.rustext',
+            'hg-cpython',
+            'librusthg',
+        ),
+        RustStandaloneExtension(
+            'mercurial.pyo3_rustext',
+            'hg-pyo3',
+            'librusthgpyo3',
+        ),
+    ]
 
 sys.path.insert(0, 'contrib/python-zstandard')
 import setup_zstd