diff setup.py @ 44852:fd3b94f1712d

merge with stable
author Martin von Zweigbergk <martinvonz@google.com>
date Tue, 26 May 2020 08:07:24 -0700
parents 47787a48f469 91e509a12dbc
children 4c53c12b92d5
line wrap: on
line diff
--- a/setup.py	Sun May 17 18:33:45 2020 -0400
+++ b/setup.py	Tue May 26 08:07:24 2020 -0700
@@ -13,7 +13,7 @@
 # bug link: https://bugs.python.org/issue25270
 supportedpy = ','.join(
     [
-        '>=2.7',
+        '>=2.7.4',
         '!=3.0.*',
         '!=3.1.*',
         '!=3.2.*',
@@ -54,7 +54,7 @@
 # should have a chance of getting a 4.2 release, and when we ratchet
 # the version requirement forward again hopefully everyone will get
 # something that works for them.
-if sys.version_info < (2, 7, 0, 'final'):
+if sys.version_info < (2, 7, 4, 'final'):
     pip_message = (
         'This may be due to an out of date pip. '
         'Make sure you have pip >= 9.0.1.'
@@ -74,7 +74,7 @@
     except Exception:
         pass
     error = """
-Mercurial does not support Python older than 2.7.
+Mercurial does not support Python older than 2.7.4.
 Python {py} detected.
 {pip}
 """.format(