diff setup.py @ 1187:b0e2c949c34b beta

Fixed Windows installation based on work of Mantis406 fork: "Replace py-bcrypt to make Windows installation easier" RhodeCode will now detect the platform and use sha256 hashes when used on Windows.
author Marcin Kuzminski <marcin@python-works.com>
date Wed, 09 Mar 2011 19:08:34 +0100
parents 918c0b600a06
children 0e6035a85980
line wrap: on
line diff
--- a/setup.py	Wed Mar 09 16:34:29 2011 +0100
+++ b/setup.py	Wed Mar 09 19:08:34 2011 +0100
@@ -1,5 +1,6 @@
 import sys
 from rhodecode import get_version
+from rhodecode import __platform__
 
 py_version = sys.version_info
 
@@ -13,7 +14,6 @@
         "mercurial>=1.7.5",
         "whoosh>=1.3.4",
         "celery>=2.2.4",
-        "py-bcrypt",
         "babel",
     ]
 
@@ -29,6 +29,10 @@
     requirements.append("simplejson")
     requirements.append("pysqlite")
 
+if __platform__ in ('Linux', 'Darwin'):
+    requirements.append("py-bcrypt")
+
+
 #additional files from project that goes somewhere in the filesystem
 #relative to sys.prefix
 data_files = []