diff setup.py @ 2050:b1ad9efeec14 beta

fixed requires files, added distinction on win vs other platforms
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 28 Jan 2012 18:07:20 +0200
parents 363f5dce1a95
children fc6063e6630b
line wrap: on
line diff
--- a/setup.py	Sat Jan 28 07:14:34 2012 +0200
+++ b/setup.py	Sat Jan 28 18:07:20 2012 +0200
@@ -1,8 +1,6 @@
 import sys
 from rhodecode import get_version
-from rhodecode import __platform__
 from rhodecode import __license__
-from rhodecode import PLATFORM_OTHERS
 from rhodecode import requirements
 
 py_version = sys.version_info
@@ -27,13 +25,6 @@
                'Programming Language :: Python :: 2.6',
                'Programming Language :: Python :: 2.7', ]
 
-if py_version < (2, 6):
-    requirements.append("simplejson")
-    requirements.append("pysqlite")
-
-if __platform__ in PLATFORM_OTHERS:
-    requirements.append("py-bcrypt")
-
 
 # additional files from project that goes somewhere in the filesystem
 # relative to sys.prefix